간단한 WAN을 구성하여 Leased Line (전용회선) 의 캡슐화 프로토콜인 PPP를 구현해 보자.
Leased Line
- 영어로는 임대회선이나 일반적으로 전용선이라 부른다.
- 전화국과 같은 통신 사업자에게 통신회선을 임대 받아서 쓰는 방식이다.
Router 3 설정
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int se 0/0/0
R1(config-if)#encapsulation ? - 캡슐화 프로토콜의 종류
frame-relay Frame Relay networks
hdlc Serial HDLC synchronous
ppp Point-to-Point protocol
R1(config-if)#enc ppp ?
<cr>
R1(config-if)#enc ppp
R1(config-if)#clock rate 64000
R1(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R1(config-if)#ip add 10.1.12.1 255.255.255.0
R1(config-if)#exit
R1(config)#do ping 10.1.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:
R1(config)#!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms
R1(config)#do show int se 0/0/0 - serial 0/0/0 에 대한 자세한 정보를 볼 수 있다. 트러블 슈팅때 이용
Serial0/0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 10.1.12.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 3 bits/sec, 0 packets/sec
5 minute output rate 4 bits/sec, 0 packets/sec
10 packets input, 400 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
10 packets output, 400 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets - 문제가 발생하면 errors, collisions 부분의 숫자가 늘어난다.
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
- 새로운 시리얼 포트에 추가 -
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#int se 0/0/1
R1(config-if)#enc ?
frame-relay Frame Relay networks
hdlc Serial HDLC synchronous
ppp Point-to-Point protocol
R1(config-if)#enc hdlc
R1(config-if)#clock rate 64000
R1(config-if)#ip add 172.16.12.1 255.255.255.0
R1(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
R1(config-if)#end
%SYS-5-CONFIG_I: Configured from console by console
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R1#show run
!
interface Serial0/0/0
ip address 10.1.12.1 255.255.255.0
encapsulation ppp
clock rate 64000
!
interface Serial0/0/1
ip address 172.16.12.1 255.255.255.0
clock rate 64000
!
R1#ping 172.16.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/28/32 ms
R1#ping 10.1.12.2 - 서로 캡슐화 프로토콜이 틀려도 연결 되어 있기 때문에 통신이 가능하다.
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms
R1#show ip int se 0/0/1
Serial0/0/1 is up, line protocol is up (connected)
Internet address is 172.16.12.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
R1#show ip int se 0/0/0
Serial0/0/0 is up, line protocol is up (connected)
Internet address is 10.1.12.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP Fast switching turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
------------------------------------------------------------------------------------------------------------------
Router 4 설정
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int se 0/0/0
R2(config-if)#enc ppp
R2(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#ip add 10.1.12.2 255.255.255.0
R2(config-if)#exit
R2(config)#do ping 10.1.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.1, timeout is 2 seconds:
R2(config)#!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms
R2(config)#do show int se 0/0/0
Serial0/0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 10.1.12.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 3 bits/sec, 0 packets/sec
5 minute output rate 3 bits/sec, 0 packets/sec
10 packets input, 400 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
10 packets output, 400 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up
- 새로운 시리얼 포트에 추가 -
R2(config)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES manual administratively down down
FastEthernet0/1 unassigned YES manual administratively down down
Serial0/0/0 10.1.12.2 YES manual up up
Serial0/0/1 unassigned YES manual administratively down down
Vlan1 unassigned YES manual administratively down down
R2(config)#do show run
!
interface Serial0/0/0
ip address 10.1.12.2 255.255.255.0
encapsulation ppp
!
interface Serial0/0/1
no ip address
shutdown -----------> administratively down이 나타나는 이유는 shutdown되었기 때문이다.
!
interface Vlan1
no ip address
shutdown
!
R2(config)#int se 0/0/1
R2(config-if)#enc hdlc
R2(config-if)#ip add 172.16.12.2 255.255.255.0
R2(config-if)#no sh
%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up
R2(config-if)#exit
R2(config)#do ping 172.16.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
R2(config)#!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 17/28/32 ms
'CCNA 기초' 카테고리의 다른 글
ACL(Access List) - Extended Access List (0) | 2008.12.05 |
---|---|
ACL(Access List) - Standard Access List (0) | 2008.12.05 |
WAN - Frame Relay (0) | 2008.12.04 |
Wireless LAN (0) | 2008.12.04 |
CDP (Cisco Discovery Protocol) (0) | 2008.12.04 |
Router Flash Backup (0) | 2008.12.04 |