NAT (Network Address Translation) 용어
- 내부 로컬 Address : 내부 내트워크의 하나의 호스트에게 할당된 사설 주소 (사설 IP)
- 내부 글로벌 Address : 인터넷 서비스 제공 업체에서 할당한 정규적인 IP 주소로 외부로 나갈 때 사용한다. (고정 IP)
- 외부 로컬 Address : 외부 호스트의 IP주소로써 내부에서 보이는 주소 값으로 DNS 서버의 주소
- 외부 글로벌 Address : 외부 호스트에 할당 된 실제 외부 호스트의 IP 주소
Static NAT 설정
Router(config)#ip nat inside source static local-ip global-ip
- local-ip gloabl-ip : 내부 로컬 주소와 내부 글로벌 주소간 정적 변환 수립
- ip nat inside : NAT에 대한 내부 네트워크가 연결된 것 표시, 인터페이스 구성모드에서 실행
- ip nat outside : NAT에 대한 외부 네트워크에 연결된 것으로 표시, 인터페이스 구성 모드에서 실행
- 외부 <----outside----- Router -----inside-----> 내부
-----------------------------------------------------------------------------------------------------
정적 NAT 설정
정적 NAT 설정을 통해 10.1.1.2 호스트의 인터넷 접근이 가능하게 하시오.
Router 0 설정
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/1
Router(config-if)#ip add 10.1.1.1 255.255.255.0
Router(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Router(config-if)#exit
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#do ping 10.1.1.2 - PC0의 설정이 끝난 후 연결 확인
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
Router(config)#.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 2/3/5 ms
Router(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config)#do ping 192.168.1.2 - router 1의 설정이 끝난 후 연결 확인
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
Router(config)#.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 2/4/6 ms
- 정적 NAT 설정 -
Router(config)#ip nat inside source static 10.1.1.2 192.168.1.3
- 10.1.1.2과 192.168.1.3을 정적 NAT 설정으로 연결을 시킨다.
Router(config)#int fa 0/1
Router(config-if)#ip nat inside - interface 0/1이 내부 네트워크로 연결된 포트이다.
Router(config-if)#exit
Router(config)#int fa 0/0
Router(config-if)#ip nat outside - interface 0/0이 외부 네트워크로 연결된 포트이다.
Router(config-if)#exit
-----------------------------------------------------------------------------------------------------
Router 1 설정
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#ip add 192.168.1.2 255.255.255.0
Router(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
-----------------------------------------------------------------------------------------------------
설정 확인 - Router 0
Router(config)#do show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES manual up up
FastEthernet0/1 10.1.1.1 YES manual up up
Vlan1 unassigned YES manual administratively down down
Router(config)#do show run
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source static 10.1.1.2 192.168.1.3
ip classless
!
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 192.168.1.3 10.1.1.2 --- ---
Router#debug ip nat ?
<cr>
Router#debug ip nat
----------- PC0의 Command Prompt 에서 Ping 실행 ----------------------------------------------
Packet Tracer PC Command Line 1.0
PC>ping 192.168.1.2
Pinging 192.168.1.2 with 32 bytes of data:
Request timed out.
Reply from 192.168.1.2: bytes=32 time=8ms TTL=254
Reply from 192.168.1.2: bytes=32 time=10ms TTL=254
Reply from 192.168.1.2: bytes=32 time=7ms TTL=254
Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 7ms, Maximum = 10ms, Average = 8ms
-----------------------------------------------------------------------------------------------------
IP NAT debugging is on
Router#
NAT: s=10.1.1.2->192.168.1.3, d=192.168.1.2[0]
Router#
NAT: s=10.1.1.2->192.168.1.3, d=192.168.1.2[0]
NAT*: s=192.168.1.2, d=192.168.1.3->10.1.1.2[0]
Router#
NAT: s=10.1.1.2->192.168.1.3, d=192.168.1.2[0]
Router#
NAT*: s=192.168.1.2, d=192.168.1.3->10.1.1.2[0]
Router#
NAT: s=10.1.1.2->192.168.1.3, d=192.168.1.2[0]
NAT*: s=192.168.1.2, d=192.168.1.3->10.1.1.2[0]
Router#
'CCNA 기초' 카테고리의 다른 글
라우터에 원격 접속 - Telnet (0) | 2008.12.05 |
---|---|
Overload NAT (0) | 2008.12.05 |
Dynamic NAT(Network Address Translation) (0) | 2008.12.05 |
ACL(Access List) - Extended Access List (0) | 2008.12.05 |
ACL(Access List) - Standard Access List (0) | 2008.12.05 |
WAN - Frame Relay (0) | 2008.12.04 |